Find answers, ask questions, and connect with others in our UK cycling & mountain bike forum.

  • How do I solve this brake problem?

     badblood updated 11 years, 6 months ago 4 Members · 7 Posts
    This page may contain affiliate links which means that Cycling Addicts earns from qualifying purchases. See our full disclosure. This page may contain affiliate links.
  • dagza

    Member
    4 July 2009 at 11:42 am

    Have a look at this:

    The left pad drags on the rim. I have been told to adjust the top screw (above the sora label) and that helped a lot but it wasn’t perfect (too much play) so I tried the adjust the cable with no luck.

    I can centre the brake with my hand but it always springs back to this position when I leave go or after I have applied and released the rear brake.

    All help and comments welcome.

    Thanks

    Darren

  • tomlevell

    Member
    4 July 2009 at 12:44 pm

    Undo the bolt holding the brake on and centre the brake on the wheel and tighten.

    Do both sides spring back the same amount then?

  • Gunner

    Member
    4 July 2009 at 1:39 pm

    Undo the bolt holding the brake on and centre the brake on the wheel and tighten.

    Do both sides spring back the same amount then?

    I agree, looks pretty much like a loose mounting bolt causing the brakes to turn to the side, as Tom says, loosen, re-position and tighten, that should do the trick, but nip it up tight.

  • dagza

    Member
    4 July 2009 at 5:10 pm

    Ah brilliant. That seems to have fixed it. These built in dad skills have seemed to have skipped my generation in our family 😳

    Thanks for the help

  • badblood

    Member
    4 July 2009 at 7:50 pm

    His wife tightened the bolt for him 😉

  • dagza

    Member
    4 July 2009 at 9:13 pm

    Actually, she held the cable whilst I tightened it 😆

    You spying on me now?

  • badblood

    Member
    5 July 2009 at 9:31 am

Viewing 1 - 7 of 7 posts
Original Post
0 of 0 posts June 2018
Now

New Report

Close